Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 1 | require links.inc |
| 2 | |
| 3 | DEPENDS += "virtual/libx11" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 4 | RCONFLICTS:${PN} = "links" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 5 | |
| 6 | inherit features_check |
| 7 | # depends on virtual/libx11 |
| 8 | REQUIRED_DISTRO_FEATURES = "x11" |
| 9 | |
| 10 | SRC_URI += " file://links2.desktop \ |
| 11 | http://www.xora.org.uk/oe/links2.png;name=icon" |
| 12 | |
| 13 | SRC_URI[sha256sum] = "0364986b3a7f1e8e3171bea362b53f71e1dd3360a8842d66fdc65580ebc2084d" |
| 14 | SRC_URI[icon.sha256sum] = "eddcd8b8c8698aa621d1a453943892d77b72ed492e0d14e0dbac5c6a57e52f47" |
| 15 | |
| 16 | S = "${WORKDIR}/links-${PV}" |
| 17 | |
| 18 | EXTRA_OECONF = "--enable-graphics \ |
| 19 | --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \ |
| 20 | --without-libtiff --without-svgalib --without-fb \ |
| 21 | --without-directfb --without-pmshell --without-atheos \ |
| 22 | --with-x --without-gpm" |
| 23 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 24 | do_install:append() { |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 25 | install -d ${D}/${datadir}/applications |
| 26 | install -m 0644 ${WORKDIR}/links2.desktop ${D}/${datadir}/applications |
| 27 | install -d ${D}/${datadir}/pixmaps |
| 28 | install -m 0644 ${WORKDIR}/links2.png ${D}/${datadir}/pixmaps |
| 29 | } |