Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Satyr is a collection of low-level algorithms for program \ |
| 2 | failure processing, analysis, and reporting supporting kernel space, user \ |
| 3 | space, Python, and Java programs" |
| 4 | |
| 5 | HOMEPAGE = "https://github.com/abrt/satyr" |
| 6 | LICENSE = "GPLv2" |
| 7 | |
| 8 | inherit autotools-brokensep python3native pkgconfig |
| 9 | |
| 10 | SRC_URI = "git://github.com/abrt/satyr.git \ |
| 11 | file://0002-fix-compile-failure-against-musl-C-library.patch \ |
| 12 | " |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 13 | SRCREV = "ad0030f071b7ce7eb748eca3c31cb381038e2b21" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 17 | |
| 18 | DEPENDS += " \ |
| 19 | gdb \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 20 | gperf-native \ |
| 21 | json-c \ |
| 22 | nettle \ |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 23 | glib-2.0 \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | " |
| 25 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 26 | PACKAGES += "python3-${BPN}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 27 | FILES:python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | |
| 29 | PACKAGECONFIG ??= "python3 rpm" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 30 | PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3" |
| 31 | PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm" |
| 32 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 33 | do_configure:prepend() { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 34 | ${S}/gen-version |
| 35 | } |