Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | # Copyright (C) 2020 Jens Rehsack <sno@netbsd.org> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "A module to implement some of AutoConf macros in pure perl" |
| 5 | DESCRIPTION = "Config::AutoConf is intended to provide the same opportunities to Perl \ |
| 6 | developers as GNU Autoconf <http://www.gnu.org/software/autoconf/> does for \ |
| 7 | Shell developers." |
| 8 | |
| 9 | HOMEPAGE= "https://metacpan.org/release/Config-AutoConf" |
| 10 | |
| 11 | SECTION = "libs" |
| 12 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 13 | |
| 14 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \ |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 15 | file://${COMMON_LICENSE_DIR}/GPL-1.0-or-later;md5=30c0b8a5048cc2f4be5ff15ef0d8cf61" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 16 | |
| 17 | SRC_URI = "${CPAN_MIRROR}/authors/id/R/RE/REHSACK/Config-AutoConf-${PV}.tar.gz" |
| 18 | |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 19 | SRC_URI[md5sum] = "eeeab8cc93eef7dd2e2c343ecdf247b7" |
| 20 | SRC_URI[sha256sum] = "304f66cc2653264c0fe127d21669e86d3d18cd72f2574d8f5131beec31a0a33e" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 21 | RDEPENDS:${PN} += "libcapture-tiny-perl" |
| 22 | RDEPENDS:${PN} += "perl-module-base" |
| 23 | RDEPENDS:${PN} += "perl-module-carp" |
| 24 | RDEPENDS:${PN} += "perl-module-config" |
| 25 | RDEPENDS:${PN} += "perl-module-constant" |
| 26 | RDEPENDS:${PN} += "perl-module-file-basename" |
| 27 | RDEPENDS:${PN} += "perl-module-file-spec" |
| 28 | RDEPENDS:${PN} += "perl-module-file-temp" |
| 29 | RDEPENDS:${PN} += "perl-module-extutils-cbuilder" |
| 30 | RDEPENDS:${PN} += "perl-module-extutils-cbuilder-platform-unix" |
| 31 | RDEPENDS:${PN} += "perl-module-scalar-util" |
| 32 | RDEPENDS:${PN} += "perl-module-strict" |
| 33 | RDEPENDS:${PN} += "perl-module-text-parsewords" |
| 34 | RDEPENDS:${PN} += "perl-module-warnings" |
| 35 | RRECOMMENDS:${PN} += "libfile-slurper-perl" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 36 | |
| 37 | S = "${WORKDIR}/Config-AutoConf-${PV}" |
| 38 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 39 | inherit cpan ptest-perl |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 40 | |
| 41 | BBCLASSEXTEND = "native nativesdk" |