Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Data::HexDump - Hexadecial Dumper" |
| 2 | DESCRIPTION = "Dump in hexadecimal the content of a scalar. The result \ |
| 3 | is returned in a string. Each line of the result consists of the offset \ |
| 4 | in the source in the leftmost column of each line, followed by one or \ |
| 5 | more columns of data from the source in hexadecimal. The rightmost column \ |
| 6 | of each line shows the printable characters \ |
| 7 | (all others are shown as single dots).\ |
| 8 | " |
| 9 | |
| 10 | HOMEPAGE = "http://search.cpan.org/~ftassin/Data-HexDump-0.02/lib/Data/HexDump.pm" |
| 11 | SECTION = "libs" |
| 12 | |
| 13 | LICENSE = "Artistic-1.0" |
| 14 | LIC_FILES_CHKSUM = "file://lib/Data/HexDump.pm;beginline=215;endline=217;md5=bf1cd9373f8d1f85fe091ee069a480e9" |
| 15 | |
| 16 | DEPENDS = "perl" |
| 17 | |
| 18 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/F/FT/FTASSIN/Data-HexDump-${PV}.tar.gz \ |
| 19 | file://run-ptest \ |
| 20 | " |
| 21 | SRC_URI[md5sum] = "467b7183d1062ab4a502b50c34e7d67f" |
| 22 | SRC_URI[sha256sum] = "1a9d843e7f667c1c6f77c67af5d77e7462ff23b41937cb17454d03535cd9be70" |
| 23 | |
| 24 | S = "${WORKDIR}/Data-HexDump-${PV}" |
| 25 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 26 | inherit cpan ptest update-alternatives |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 27 | |
| 28 | do_install_ptest () { |
| 29 | install -d ${D}${PTEST_PATH}/t |
| 30 | install -m 0755 ${B}/t/* ${D}${PTEST_PATH}/t |
| 31 | } |
| 32 | |
| 33 | BBCLASSEXTEND = "native" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 34 | |
| 35 | ALTERNATIVES_PRIORITY = "100" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 36 | ALTERNATIVE:${PN} = "hexdump" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 37 | ALTERNATIVE_LINK_NAME[hexdump] = "${bindir}/hexdump" |
| 38 | |