Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "This package contains the DNS.pm module with friends." |
| 2 | HOMEPAGE = "http://www.net-dns.org/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "MIT" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://README;beginline=252;endline=269;md5=27db37b42cd1a5173a53922d67072bcb" |
| 7 | |
| 8 | DEPENDS += "perl" |
| 9 | |
| 10 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/N/NL/NLNETLABS/Net-DNS-${PV}.tar.gz" |
| 11 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 12 | SRC_URI[sha256sum] = "b890a7b44d573f27cc713caadf1e12eaaa4478a6504d1157194df614316b5b50" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
| 14 | UPSTREAM_CHECK_REGEX = "Net\-DNS\-(?P<pver>(\d+\.\d+))(?!_\d+).tar" |
| 15 | |
| 16 | S = "${WORKDIR}/Net-DNS-${PV}" |
| 17 | |
| 18 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" |
| 19 | |
| 20 | inherit cpan ptest-perl |
| 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 22 | RDEPENDS:${PN} = " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | libdigest-hmac-perl \ |
| 24 | perl-module-base \ |
| 25 | perl-module-constant \ |
| 26 | perl-module-digest-md5 \ |
| 27 | perl-module-digest-sha \ |
| 28 | perl-module-file-spec \ |
| 29 | perl-module-integer \ |
| 30 | perl-module-io-file \ |
| 31 | perl-module-io-select \ |
| 32 | perl-module-io-socket \ |
| 33 | perl-module-io-socket-ip \ |
| 34 | perl-module-mime-base64 \ |
| 35 | perl-module-scalar-util \ |
| 36 | perl-module-test-more \ |
| 37 | perl-module-time-local \ |
| 38 | " |
| 39 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 40 | RRECOMMENDS:${PN} += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 41 | libnet-dns-sec-perl \ |
| 42 | " |
| 43 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 44 | RDEPENDS:${PN}-ptest += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 45 | perl-module-encode \ |
| 46 | perl-module-encode-byte \ |
| 47 | perl-module-extutils-mm \ |
| 48 | perl-module-extutils-mm-unix \ |
| 49 | perl-module-overload \ |
| 50 | " |
| 51 | |
| 52 | python __anonymous () { |
| 53 | # rather than use "find" to determine libc-*.so, |
| 54 | # statically export the known paths for glibc and musl |
| 55 | import os |
| 56 | if d.getVar('TCLIBC') == "glibc": |
| 57 | os.environ["LIBC"] = "${STAGING_BASELIBDIR}/libc.so.6" |
| 58 | elif d.getVar('TCLIBC') == "musl": |
| 59 | os.environ["LIBC"] = "${STAGING_LIBDIR}/libc.so" |
| 60 | else: |
| 61 | raise bb.parse.SkipRecipe("incompatible with %s C library" % |
| 62 | d.getVar('TCLIBC')) |
| 63 | } |
| 64 | |
| 65 | BBCLASSEXTEND = "native" |