Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Term::ReadKey - A perl module for simple terminal control." |
| 2 | DESCRIPTION = "Term::ReadKey is a compiled perl module dedicated to providing simple \ |
| 3 | control over terminal driver modes (cbreak, raw, cooked, etc.,) support \ |
| 4 | for non-blocking reads, if the architecture allows, and some generalized \ |
| 5 | handy functions for working with terminals. One of the main goals is to \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 6 | have the functions as portable as possible, so you can just plug in 'use \ |
| 7 | Term::ReadKey' on any architecture and have a good likelihood of it \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 8 | working." |
| 9 | HOMEPAGE = "http://search.cpan.org/~jstowe/TermReadKey-${PV}" |
| 10 | SECTION = "libraries" |
| 11 | |
| 12 | LICENSE = "Artistic-1.0 | GPLv1+" |
| 13 | LIC_FILES_CHKSUM = "file://README;md5=c275db663c8489a5709ebb22b185add5" |
| 14 | |
| 15 | SRC_URI = "${CPAN_MIRROR}/authors/id/J/JS/JSTOWE/TermReadKey-${PV}.tar.gz" |
| 16 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 17 | SRC_URI[md5sum] = "b2b4aab7a0e6bddb7ac3b21ba637482c" |
| 18 | SRC_URI[sha256sum] = "5a645878dc570ac33661581fbb090ff24ebce17d43ea53fd22e105a856a47290" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/TermReadKey-${PV}" |
| 21 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 22 | UPSTREAM_CHECK_URI = "https://metacpan.org/release/TermReadKey" |
| 23 | UPSTREAM_CHECK_REGEX = "TermReadKey\-(?P<pver>(\d+\.\d+))(?!_\d+)\.tar.gz" |
| 24 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 25 | # It needs depend on native to let dynamic loader use native modules |
| 26 | # rather than target ones. |
| 27 | DEPENDS = "libterm-readkey-perl-native" |
| 28 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 29 | inherit cpan ptest-perl |
| 30 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 31 | RDEPENDS:${PN}-ptest += " \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 32 | perl-module-test-more \ |
| 33 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 34 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 35 | do_configure:append () { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 36 | # Hack the dynamic module loader so that it use native modules since it can't load |
| 37 | # the target ones. |
| 38 | if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then |
| 39 | sed -i -e "s#-I\$(INST_ARCHLIB)#-I${STAGING_BINDIR_NATIVE}/perl-native/perl/vendor_perl/${@get_perl_version(d)}#g" Makefile |
| 40 | fi |
| 41 | } |
| 42 | |
| 43 | BBCLASSEXTEND = "native" |