Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "An abstract syntax tree for Python with inference support." |
| 2 | HOMEPAGE = "https://pypi.python.org/pypi/astroid" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "LGPL-2.1" |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a70cf540abf41acb644ac3b621b2fad1" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 6 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "83e494b02d75d07d4e347b27c066fd791c0c74fc96c613d1ea3de0c82c48168f" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 8 | |
| 9 | inherit pypi setuptools3 |
| 10 | |
| 11 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" |
| 12 | |
| 13 | PACKAGES =+ "${PN}-tests" |
| 14 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 15 | FILES:${PN}-tests += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | ${PYTHON_SITEPACKAGES_DIR}/astroid/test* \ |
| 17 | ${PYTHON_SITEPACKAGES_DIR}/astroid/__pycache__/test* \ |
| 18 | " |
| 19 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 20 | RDEPENDS:${PN}:class-target += "\ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 21 | ${PYTHON_PN}-distutils \ |
| 22 | ${PYTHON_PN}-lazy-object-proxy \ |
| 23 | ${PYTHON_PN}-logging \ |
| 24 | ${PYTHON_PN}-six \ |
| 25 | ${PYTHON_PN}-wrapt \ |
| 26 | ${PYTHON_PN}-setuptools \ |
| 27 | " |
| 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 29 | RDEPENDS:${PN}-tests:class-target += "\ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 30 | ${PYTHON_PN}-unittest \ |
| 31 | ${PYTHON_PN}-xml \ |
| 32 | " |