Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "SDK for connecting to AWS IoT using Python." |
| 2 | HOMEPAGE = "https://github.com/aws/aws-iot-device-sdk-python" |
| 3 | LICENSE = "Apache-2.0 & (EPL-1.0 | EDL-1.0)" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 4 | LICENSE:${PN}-examples = "Apache-2.0" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "\ |
| 6 | file://LICENSE.txt;md5=9ac49901b833e769c7d6f21e8dbd7b30 \ |
| 7 | file://AWSIoTPythonSDK/core/protocol/paho/client.py;endline=14;md5=5a3c8a1a4bb71bd934f450ecff972ad9 \ |
| 8 | " |
| 9 | |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 10 | SRC_URI[sha256sum] = "84b440c5929f33da1cd204f3ad0ea891e208637dd63de9fb039ed7d49d78c303" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | |
| 12 | inherit pypi setuptools3 |
| 13 | |
| 14 | PYPI_PACKAGE = "AWSIoTPythonSDK" |
| 15 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 16 | do_install:append() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | install -d -m0755 ${D}${datadir}/${BPN}/examples |
| 18 | cp --preserve=mode,timestamps -R ${S}/samples/* ${D}${datadir}/${BPN}/examples |
| 19 | # this requires the full blown AWS Python SDK |
| 20 | rm -r ${D}${datadir}/${BPN}/examples/basicPubSub |
| 21 | } |
| 22 | |
| 23 | PACKAGES =+ "${PN}-examples" |
| 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 25 | RDEPENDS:${PN} += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | ${PYTHON_PN}-crypt \ |
| 27 | ${PYTHON_PN}-datetime \ |
| 28 | ${PYTHON_PN}-io \ |
| 29 | ${PYTHON_PN}-json \ |
| 30 | ${PYTHON_PN}-logging \ |
| 31 | ${PYTHON_PN}-math \ |
| 32 | ${PYTHON_PN}-netclient \ |
| 33 | ${PYTHON_PN}-numbers \ |
| 34 | ${PYTHON_PN}-threading \ |
| 35 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 36 | RDEPENDS:${PN}-examples += "${PN}" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 38 | FILES:${PN}-examples = "${datadir}/${BPN}/examples" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 39 | |
| 40 | BBCLASSEXTEND = "native nativesdk" |