Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Debugging and profiling extension for PHP" |
| 2 | LICENSE = "Xdebug" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=92d94a330d34ee6edc2638450736f119" |
| 4 | |
| 5 | DEPENDS = "php re2c-native" |
| 6 | |
| 7 | SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz" |
| 8 | |
| 9 | SRC_URI[md5sum] = "c04be1bf225b768bf627dc92e5a1f9df" |
| 10 | SRC_URI[sha256sum] = "775b1705109611b996d6a713fe14117a67846e157eb7dbf349bc0b055e861a10" |
| 11 | |
| 12 | UPSTREAM_CHECK_REGEX = "xdebug-(?P<pver>\d+(\.\d+)+)\.tgz" |
| 13 | |
| 14 | inherit autotools |
| 15 | |
| 16 | EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config" |
| 17 | |
| 18 | do_configure() { |
| 19 | cd ${S} |
| 20 | ${STAGING_BINDIR_CROSS}/phpize |
| 21 | cd ${B} |
| 22 | |
| 23 | # Running autoreconf as autotools_do_configure would do here |
| 24 | # breaks the libtool configuration resulting in a failure later |
| 25 | # in do_compile. It's possible this may be fixable, however the |
| 26 | # easiest course of action for the moment is to avoid doing that. |
| 27 | oe_runconf |
| 28 | } |
| 29 | |
| 30 | do_install() { |
| 31 | oe_runmake install INSTALL_ROOT=${D} |
| 32 | } |
| 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 34 | FILES:${PN} += "${libdir}/php*/extensions/*/*.so" |
| 35 | FILES:${PN}-dbg += "${libdir}/php*/extensions/*/.debug" |