Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | HOMEPAGE = "https://github.com/firehol/netdata/" |
| 2 | SUMMARY = "Real-time performance monitoring" |
| 3 | LICENSE = "GPLv3" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=fc9b848046ef54b5eaee6071947abd24" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 5 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 6 | SRC_URI = "git://github.com/firehol/netdata.git;protocol=https" |
| 7 | SRCREV = "1be9200ba8e11dc81a2101d85a2725137d43f766" |
| 8 | PV = "1.22.1" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 9 | |
| 10 | # default netdata.conf for netdata configuration |
| 11 | SRC_URI += "file://netdata.conf" |
| 12 | |
| 13 | # file for providing systemd service support |
| 14 | SRC_URI += "file://netdata.service" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 18 | DEPENDS += "zlib util-linux libuv" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 19 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 20 | inherit pkgconfig autotools-brokensep useradd systemd |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 22 | LIBS:toolchain-clang:x86 = "-latomic" |
| 23 | LIBS:riscv64 = "-latomic" |
| 24 | LIBS:riscv32 = "-latomic" |
Brad Bishop | a891d15 | 2019-09-13 06:17:45 -0400 | [diff] [blame] | 25 | export LIBS |
| 26 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 27 | #systemd |
| 28 | SYSTEMD_PACKAGES = "${PN}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 29 | SYSTEMD_SERVICE:${PN} = "netdata.service" |
| 30 | SYSTEMD_AUTO_ENABLE:${PN} = "enable" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 31 | |
| 32 | #User specific |
| 33 | USERADD_PACKAGES = "${PN}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 34 | GROUPADD_PARAM:${PN} = "--system netdata" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 35 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 36 | do_install:append() { |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 37 | #set S UID for plugins |
| 38 | chmod 4755 ${D}${libexecdir}/netdata/plugins.d/apps.plugin |
| 39 | |
| 40 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
| 41 | # Install systemd unit files |
| 42 | install -d ${D}${systemd_unitdir}/system |
| 43 | install -m 0644 ${WORKDIR}/netdata.service ${D}${systemd_unitdir}/system |
| 44 | sed -i -e 's,@@datadir,${datadir_native},g' ${D}${systemd_unitdir}/system/netdata.service |
| 45 | fi |
| 46 | |
| 47 | # Install default netdata.conf |
| 48 | install -d ${D}${sysconfdir}/netdata |
| 49 | install -m 0644 ${WORKDIR}/netdata.conf ${D}${sysconfdir}/netdata/ |
| 50 | sed -i -e 's,@@sysconfdir,${sysconfdir},g' ${D}${sysconfdir}/netdata/netdata.conf |
| 51 | sed -i -e 's,@@libdir,${libexecdir},g' ${D}${sysconfdir}/netdata/netdata.conf |
| 52 | sed -i -e 's,@@datadir,${datadir},g' ${D}${sysconfdir}/netdata/netdata.conf |
| 53 | } |
| 54 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 55 | RDEPENDS:${PN} = "bash zlib" |