Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Library to handle input devices in Wayland compositors" |
| 2 | DESCRIPTION = "libinput is a library to handle input devices in Wayland \ |
| 3 | compositors and to provide a generic X.Org input driver. It provides \ |
| 4 | device detection, device handling, input device event processing and \ |
| 5 | abstraction so minimize the amount of custom input code compositors need to \ |
| 6 | provide the common set of functionality that users expect." |
| 7 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/" |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | LICENSE = "MIT" |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=bab4ac7dc1c10bc0fb037dc76c46ef8a" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 13 | DEPENDS = "libevdev udev mtdev libcheck" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | |
| 15 | SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \ |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 16 | file://run-ptest \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | file://determinism.patch \ |
| 18 | " |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 19 | SRC_URI[sha256sum] = "18c6a286583268d39841348e561fbb4713bde0c643b360f5d8a3f27800afdb9a" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | |
| 21 | UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)" |
| 22 | |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 23 | inherit meson pkgconfig lib_package ptest |
| 24 | |
| 25 | # Patch out build directory, otherwise it leaks into ptest binary |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 26 | do_configure:append() { |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 27 | sed -i -e "s,${WORKDIR},,g" config.h |
| 28 | if [ -e "litest-config.h" ]; then |
| 29 | sed -i -e "s,${WORKDIR},,g" litest-config.h |
| 30 | fi |
| 31 | } |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 32 | |
| 33 | PACKAGECONFIG ??= "" |
| 34 | PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom" |
| 35 | PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3" |
| 36 | |
| 37 | UDEVDIR = "`pkg-config --variable=udevdir udev`" |
| 38 | |
| 39 | EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \ |
| 40 | -Ddocumentation=false \ |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 41 | ${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true -Dinstall-tests=true', '-Dtests=false -Dinstall-tests=false', d)} \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 42 | -Dzshcompletiondir=no" |
| 43 | |
| 44 | # package name changed in 1.8.1 upgrade: make sure package upgrades work |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 45 | RPROVIDES:${PN} = "libinput" |
| 46 | RREPLACES:${PN} = "libinput" |
| 47 | RCONFLICTS:${PN} = "libinput" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 48 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame^] | 49 | FILES:${PN}-ptest += "${libexecdir}/libinput/libinput-test-suite" |