blob: a1f3957adc8c86a8db550a1bce30007919869b1a [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Makes working with XML feel like you are working with JSON"
Brad Bishope42b3e32020-01-15 22:08:42 -05002HOMEPAGE = "https://github.com/martinblech/xmltodict"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=01441d50dc74476db58a41ac10cb9fa2"
5
Patrick Williams2194f502022-10-16 14:26:09 -05006SRC_URI[sha256sum] = "341595a488e3e01a85a9d8911d8912fd922ede5fecc4dce437eb4b6c8d037e56"
Brad Bishope42b3e32020-01-15 22:08:42 -05007
8PYPI_PACKAGE = "xmltodict"
9
Andrew Geissler82c905d2020-04-13 13:39:40 -050010inherit pypi setuptools3 ptest
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
Patrick Williams2194f502022-10-16 14:26:09 -050016RDEPENDS:${PN} += " \
17 ${PYTHON_PN}-core \
18 ${PYTHON_PN}-xml \
19 ${PYTHON_PN}-io \
20"
21
Patrick Williams213cb262021-08-07 19:21:33 -050022RDEPENDS:${PN}-ptest += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050023 ${PYTHON_PN}-pytest \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29}