Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "tool for automating interactive applications according to a script" |
| 2 | DESCRIPTION = "Expect is a tool for automating interactive applications according to a script. \ |
| 3 | Following the script, Expect knows what can be expected from a program and what \ |
| 4 | the correct response should be. Expect is also useful for testing these same \ |
| 5 | applications. And by adding Tk, you can also wrap interactive applications in \ |
| 6 | X11 GUIs. An interpreted language provides branching and high-level control \ |
| 7 | structures to direct the dialogue. In addition, the user can take control and \ |
| 8 | interact directly when desired, afterward returning control to the script. \ |
| 9 | " |
| 10 | HOMEPAGE = "http://sourceforge.net/projects/expect/" |
| 11 | LICENSE = "PD" |
| 12 | SECTION = "devel" |
| 13 | |
| 14 | LIC_FILES_CHKSUM = "file://license.terms;md5=fbf2de7e9102505b1439db06fc36ce5c" |
| 15 | |
| 16 | DEPENDS += "tcl" |
| 17 | RDEPENDS_${PN} = "tcl" |
| 18 | |
| 19 | inherit autotools |
| 20 | |
| 21 | PR = "r1" |
| 22 | |
| 23 | SRC_URI = "${SOURCEFORGE_MIRROR}/expect/Expect/${PV}/${BPN}${PV}.tar.gz \ |
| 24 | file://0001-configure.in.patch \ |
| 25 | file://0002-tcl.m4.patch \ |
| 26 | file://01-example-shebang.patch \ |
| 27 | file://0001-expect-install-scripts-without-using-the-fixline1-tc.patch \ |
| 28 | " |
| 29 | SRC_URI[md5sum] = "44e1a4f4c877e9ddc5a542dfa7ecc92b" |
| 30 | SRC_URI[sha256sum] = "b28dca90428a3b30e650525cdc16255d76bb6ccd65d448be53e620d95d5cc040" |
| 31 | |
| 32 | S = "${WORKDIR}/${BPN}${PV}" |
| 33 | |
| 34 | do_install_append() { |
| 35 | install -d ${D}${libdir} |
| 36 | install -m 0755 ${D}${libdir}/expect${PV}/libexpect*.so ${D}${libdir}/ |
| 37 | install -m 0755 ${S}/fixline1 ${D}${libdir}/expect${PV}/ |
| 38 | install -m 0755 ${S}/example/* ${D}${libdir}/expect${PV}/ |
| 39 | rm ${D}${libdir}/expect${PV}/libexpect*.so |
| 40 | sed -e 's|$dir|${libdir}|' -i ${D}${libdir}/expect${PV}/pkgIndex.tcl |
| 41 | } |
| 42 | |
| 43 | EXTRA_OECONF += "--with-tcl=${STAGING_LIBDIR} \ |
| 44 | --with-tclinclude=${STAGING_INCDIR}/tcl8.6 \ |
| 45 | --enable-shared \ |
| 46 | --enable-threads \ |
| 47 | --disable-rpath \ |
| 48 | " |
| 49 | EXTRA_OEMAKE_install = " 'SCRIPTS=' " |
| 50 | |
| 51 | FILES_${PN}-dbg += "${libdir}/${BPN}${PV}/.debug \ |
| 52 | ${libdir}/.debug \ |
| 53 | " |
| 54 | FILES_${PN}-dev = "${libdir_native}/expect${PV}/libexpect*.so \ |
| 55 | ${includedir}/expect.h \ |
| 56 | ${includedir}/expect_tcl.h \ |
| 57 | ${includedir}/expect_comm.h \ |
| 58 | ${includedir}/tcldbg.h \ |
| 59 | ${includedir}/*.h \ |
| 60 | " |
| 61 | |
| 62 | FILES_${PN} += "${libdir}/libexpect${PV}.so \ |
| 63 | ${libdir}/expect${PV}/* \ |
| 64 | " |