blob: 88afdda717ba268b7f58199fa79cb16b1701234f [file] [log] [blame]
Andrew Geissler220dafd2023-10-04 10:18:08 -05001SUMMARY = "APIFlask is a lightweight Python web API framework based on Flask and marshmallow-code projects."
2HOMEPAGE = "https://github.com/apiflask/apiflask"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5f89d1b0dec37448d4f4163dc3c40e64"
5
6inherit pypi setuptools3
7
8PYPI_PACKAGE = "APIFlask"
9
10SRC_URI[sha256sum] = "c1ab81640a1ab252888e2cc7ae556272a169b449c582abae309a8fe295f9337d"
11
12RDEPENDS:${PN} += "\
13 python3-flask \
14 python3-flask-marshmallow \
15 python3-webargs \
16 python3-flask-httpauth \
17 python3-apispec \
18 "