blob: 930ad343401fe0fc5d77bf7ac94e56d5b6e75c98 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Python wrapper around rapidjson"
2HOMEPAGE = "https://github.com/python-rapidjson/python-rapidjson"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4daf3929156304df67003c33274a98bd"
6
7SRC_URI = "git://github.com/python-rapidjson/python-rapidjson.git;protocol=https;branch=master"
Andrew Geissler220dafd2023-10-04 10:18:08 -05008SRCREV = "e1b41f64df1705770b7b70d7221a4812909c1d0f"
Andrew Geissler517393d2023-01-13 08:55:19 -06009
10S = "${WORKDIR}/git"
11
12inherit setuptools3
13
14SETUPTOOLS_BUILD_ARGS += " --rj-include-dir=${RECIPE_SYSROOT}${includedir}"
15
16DEPENDS += " \
17 rapidjson \
18"
19
20RDEPENDS:${PN} += " \
21 ${PYTHON_PN}-core \
22"