blob: c84e2225b8e285ca9dc89068d6ea5b4130986296 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A cross-platform process and system utilities module for Python"
2LICENSE = "BSD-3-Clause"
Patrick Williamsb542dec2023-06-09 01:26:37 -05003LIC_FILES_CHKSUM = "file://LICENSE;md5=a9c72113a843d0d732a0ac1c200d81b1"
Andrew Geissler9aee5002022-03-30 16:27:02 +00004HOMEPAGE = "https://pypi.org/project/psutil/"
5
Patrick Williamsb542dec2023-06-09 01:26:37 -05006SRC_URI[sha256sum] = "5410638e4df39c54d957fc51ce03048acd8e6d60abc0f5107af51e5fb566eb3c"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007
8inherit pypi setuptools3
9
Andrew Geissler9aee5002022-03-30 16:27:02 +000010PACKAGES =+ "${PN}-tests"
11
12FILES:${PN}-tests += " \
13 ${PYTHON_SITEPACKAGES_DIR}/psutil/test* \
14 ${PYTHON_SITEPACKAGES_DIR}/psutil/__pycache__/test* \
15"
16
17
18RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-threading \
21 ${PYTHON_PN}-xml \
22 ${PYTHON_PN}-netclient \
23 ${PYTHON_PN}-ctypes \
24 ${PYTHON_PN}-resource \
25"
26
Patrick Williams8e7b46e2023-05-01 14:19:06 -050027RDEPENDS:${PN}-tests += " \
28 ${PN} \
29 ${PYTHON_PN} \
30 coreutils \
31 procps \
32 binutils \
33 gcc \
34 gcc-symlinks \
35 libstdc++ \
36 libstdc++-dev \
37"
38
39INSANE_SKIP:${PN}-tests += "dev-deps"
40
Andrew Geissler028142b2023-05-05 11:29:21 -050041BBCLASSEXTEND = "native"