Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Provides support for the Tag Image File Format (TIFF)" |
| 2 | DESCRIPTION = "Library provides support for the Tag Image File Format \ |
| 3 | (TIFF), a widely used format for storing image data. This library \ |
| 4 | provide means to easily access and create TIFF image files." |
| 5 | HOMEPAGE = "http://www.libtiff.org/" |
| 6 | LICENSE = "BSD-2-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3" |
| 8 | |
| 9 | CVE_PRODUCT = "libtiff" |
| 10 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame^] | 11 | SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \ |
| 12 | " |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 13 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame^] | 14 | SRC_URI[sha256sum] = "88b3979e6d5c7e32b50d7ec72fb15af724f6ab2cbf7e10880c360a77e4b5d99a" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | |
| 16 | # exclude betas |
| 17 | UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar" |
| 18 | |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 19 | CVE_STATUS[CVE-2015-7313] = "fixed-version: Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313 and already 4.3.0 doesn't have the issue" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 20 | |
| 21 | inherit autotools multilib_header |
| 22 | |
| 23 | CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no" |
| 24 | |
| 25 | PACKAGECONFIG ?= "cxx jpeg zlib lzma \ |
| 26 | strip-chopping extrasample-as-alpha check-ycbcr-subsampling" |
| 27 | |
| 28 | PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,," |
| 29 | PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig," |
| 30 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg," |
| 31 | PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib," |
| 32 | PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz," |
| 33 | PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp," |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 34 | PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd," |
| 35 | PACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate," |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 36 | |
| 37 | # Convert single-strip uncompressed images to multiple strips of specified |
| 38 | # size (default: 8192) to reduce memory usage |
| 39 | PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,," |
| 40 | |
| 41 | # Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA |
| 42 | PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,," |
| 43 | |
| 44 | # Control picking up YCbCr subsample info. Disable to support files lacking |
| 45 | # the tag |
| 46 | PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,," |
| 47 | |
| 48 | # Support a mechanism allowing reading large strips (usually one strip files) |
| 49 | # in chunks when using TIFFReadScanline. Experimental 4.0+ feature |
| 50 | PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,," |
| 51 | |
| 52 | PACKAGES =+ "tiffxx tiff-utils" |
| 53 | FILES:tiffxx = "${libdir}/libtiffxx.so.*" |
| 54 | FILES:tiff-utils = "${bindir}/*" |
| 55 | |
| 56 | do_install:append() { |
| 57 | oe_multilib_header tiffconf.h |
| 58 | } |
| 59 | |
| 60 | BBCLASSEXTEND = "native nativesdk" |