Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 1 | DESCRIPTION = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications." |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | HOMEPAGE = "https://www.khronos.org/vulkan/" |
| 3 | BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 4 | LICENSE = "Apache-2.0" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a" |
| 7 | |
| 8 | SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git \ |
| 9 | file://0001-CMakeLists.txt-do-not-hardcode-lib-as-installation-t.patch \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 10 | file://debugfix.patch \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 11 | " |
| 12 | |
| 13 | UPSTREAM_CHECK_COMMITS = "1" |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 14 | SRCREV = "d2187278cb6632ce35920575832eb6f6e2b2e46c" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 15 | |
| 16 | UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for" |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | REQUIRED_DISTRO_FEATURES = 'vulkan' |
| 20 | |
| 21 | inherit cmake features_check |
| 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | FILES:${PN} += "${datadir}" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 24 | |
| 25 | # |
| 26 | # There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths |
| 27 | # used for logging with LOGE in the code. We need to make this match the value we use |
| 28 | # in the debug source remapping from CFLAGS |
| 29 | # |
| 30 | EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/" |
| 31 | # Binaries built with PCH enabled don't appear reproducible, differing results were seen |
| 32 | # from some builds depending on the point the PCH was compiled. Disable it to be |
| 33 | # deterministic |
| 34 | EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 35 | |
| 36 | # This needs to be specified explicitly to avoid xcb/xlib dependencies |
| 37 | EXTRA_OECMAKE += "-DVKB_WSI_SELECTION=D2D" |