Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Touchscreen calibration data from xinput-calibrator" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "A generic touchscreen calibration program for X.Org" |
| 3 | HOMEPAGE = "https://www.freedesktop.org/wiki/Software/xinput_calibrator/" |
| 4 | BUGTRACKER = "https://github.com/tias/xinput_calibrator/issues" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 7 | |
| 8 | PR = "r7" |
| 9 | |
| 10 | SRC_URI = "file://pointercal.xinput" |
| 11 | S = "${WORKDIR}" |
| 12 | |
| 13 | do_install() { |
| 14 | # Only install file if it has a contents |
| 15 | if [ -s ${S}/pointercal.xinput ] &&\ |
| 16 | [ ! -n "$(head -n1 ${S}/pointercal.xinput|grep "replace.*pointercal\.xinput")" ]; then |
| 17 | install -d ${D}${sysconfdir}/ |
| 18 | install -m 0644 ${S}/pointercal.xinput ${D}${sysconfdir}/ |
| 19 | fi |
| 20 | } |
| 21 | |
| 22 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | CONFFILES:${PN} = "${sysconfdir}/pointercal.xinput" |