Matthew Barth | c358bce | 2020-05-12 14:08:30 -0500 | [diff] [blame] | 1 | SUMMARY = "Fan watchdog services" |
| 2 | PR = "r1" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 5 | |
| 6 | inherit obmc-phosphor-systemd |
| 7 | |
| 8 | RDEPENDS_${PN} += "virtual/obmc-gpio-monitor" |
| 9 | RDEPENDS_${PN} += "busybox" |
| 10 | |
| 11 | RESET_SERVICE = "reset-fan-watchdog.service" |
| 12 | TGTFMT = "obmc-chassis-poweron@0.target" |
| 13 | RESET_FMT = "../${RESET_SERVICE}:${TGTFMT}.requires/${RESET_SERVICE}" |
| 14 | |
| 15 | MONITOR_SERVICE = "fan-watchdog-monitor@.service" |
| 16 | |
| 17 | WATCHDOG_SERVICE = "fan-watchdog.service" |
| 18 | WATCHDOG_FMT = "../${WATCHDOG_SERVICE}:${TGTFMT}.requires/${WATCHDOG_SERVICE}" |
| 19 | |
| 20 | SYSTEMD_SERVICE_${PN} += "${RESET_SERVICE} ${MONITOR_SERVICE} ${WATCHDOG_SERVICE}" |
| 21 | SYSTEMD_LINK_${PN} += "${RESET_FMT} ${WATCHDOG_FMT}" |
| 22 | SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/fan-watchdog/reset-fan-watchdog.conf" |
| 23 | SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/fan-watchdog/fan-watchdog.conf" |