Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Protocol Buffers - structured data serialisation mechanism" |
| 2 | DESCRIPTION = "This is protobuf-c, a C implementation of the Google Protocol Buffers data \ |
| 3 | serialization format. It includes libprotobuf-c, a pure C library that \ |
| 4 | implements protobuf encoding and decoding, and protoc-c, a code generator that \ |
| 5 | converts Protocol Buffer .proto files to C descriptor code, based on the \ |
| 6 | original protoc. protobuf-c formerly included an RPC implementation; that code \ |
| 7 | has been split out into the protobuf-c-rpc project." |
| 8 | HOMEPAGE = "https://github.com/protobuf-c/protobuf-c" |
| 9 | SECTION = "console/tools" |
| 10 | LICENSE = "BSD-2-Clause" |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9f725889e0d77383e26cb42b0b62cea2" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 12 | |
| 13 | DEPENDS = "protobuf-native protobuf" |
| 14 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 15 | SRC_URI = "git://github.com/protobuf-c/protobuf-c.git;branch=master;protocol=https" |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 16 | SRCREV = "abc67a11c6db271bedbb9f58be85d6f4e2ea8389" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | inherit autotools pkgconfig |
| 21 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 22 | export PROTOC = "${STAGING_BINDIR_NATIVE}/protoc" |
| 23 | |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 24 | # After several fix attempts there is still a race between generating |
| 25 | # t.test-full.pb.h and compiling cxx_generate_packed_data.c despite |
| 26 | # BUILT_SOURCES and explicit dependencies. |
| 27 | PARALLEL_MAKE = "" |
| 28 | |
| 29 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 30 | |
| 31 | FILES:${PN}-compiler = "${bindir}" |
| 32 | |
| 33 | RDEPENDS:${PN}-compiler = "protobuf-compiler" |
| 34 | RDEPENDS:${PN}-dev += "${PN}-compiler" |
| 35 | |
| 36 | BBCLASSEXTEND = "native nativesdk" |