Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Load, configure, and compose WSGI applications and servers" |
| 2 | HOMEPAGE = "https://pylonsproject.org/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://license.txt;md5=1798f29d55080c60365e6283cb49779c" |
| 5 | |
| 6 | inherit pypi |
| 7 | PYPI_PACKAGE = "PasteDeploy" |
| 8 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame^] | 9 | SRC_URI[sha256sum] = "5f4b4d5fddd39b8947ea727161e366bf55b90efc60a4d1dd7976b9031d0b4e5f" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 10 | |
| 11 | S = "${WORKDIR}/PasteDeploy-${PV}" |
| 12 | |
| 13 | inherit setuptools3 |
| 14 | |
| 15 | # Uncomment this line to enable all the optional features. |
| 16 | #PACKAGECONFIG ?= "paste docs" |
| 17 | PACKAGECONFIG[paste] = ",,,python3-paste" |
| 18 | PACKAGECONFIG[docs] = ",,,python3-sphinx python3-pylons-sphinx-themes" |
| 19 | |
| 20 | DEPENDS= "python3 python3-setuptools-scm-native python3-pytest-runner-native" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | RDEPENDS:${PN} += "python3-core python3-misc python3-netclient python3-pkgutil python3-setuptools python3-threading python3-core" |