Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Utility that provides userspace support for reading and writing to the i.MX fuses" |
| 2 | LICENSE = "BSD-3-Clause" |
| 3 | LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=201414b6610203caed355323b1ab3116" |
| 4 | |
| 5 | GO_IMPORT = "github.com/usbarmory/crucible" |
| 6 | SRC_URI = "git://${GO_IMPORT}.git;protocol=https;branch=master" |
| 7 | |
| 8 | GO_INSTALL = "\ |
| 9 | ${GO_IMPORT}/cmd/crucible \ |
| 10 | ${GO_IMPORT}/cmd/habtool \ |
| 11 | " |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 12 | SRCREV = "dec27cd4e0e0db106c0a21d429c04ca8d36bbdd5" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 13 | |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 14 | export GOPROXY = "https://proxy.golang.org,direct" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 15 | # Workaround for network access issue during compile step. |
| 16 | # This needs to be fixed in the recipes buildsystem so that |
| 17 | # it can be accomplished during do_fetch task. |
| 18 | do_compile[network] = "1" |
| 19 | |
| 20 | inherit go-mod |