blob: d53e1a276bca75282992a152d21f510daa9f06f4 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Utility that provides userspace support for reading and writing to the i.MX fuses"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=201414b6610203caed355323b1ab3116"
4
5GO_IMPORT = "github.com/usbarmory/crucible"
6SRC_URI = "git://${GO_IMPORT}.git;protocol=https;branch=master"
7
8GO_INSTALL = "\
9 ${GO_IMPORT}/cmd/crucible \
10 ${GO_IMPORT}/cmd/habtool \
11"
Patrick Williamsb58112e2024-03-07 11:16:36 -060012SRCREV = "dec27cd4e0e0db106c0a21d429c04ca8d36bbdd5"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060013
Patrick Williamsb58112e2024-03-07 11:16:36 -060014export GOPROXY = "https://proxy.golang.org,direct"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060015# Workaround for network access issue during compile step.
16# This needs to be fixed in the recipes buildsystem so that
17# it can be accomplished during do_fetch task.
18do_compile[network] = "1"
19
20inherit go-mod