Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Parallelism library for C++ - runtime files \ |
| 2 | TBB is a library that helps you leverage multi-core processor \ |
| 3 | performance without having to be a threading expert. It represents a \ |
| 4 | higher-level, task-based parallelism that abstracts platform details \ |
| 5 | and threading mechanism for performance and scalability." |
| 6 | HOMEPAGE = "https://software.intel.com/en-us/tbb" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=86d3f3a95c324c9479bd8986968f4327" |
| 9 | |
| 10 | DEPENDS:append:libc-musl = " libucontext" |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 11 | DEPENDS:append:class-target = " hwloc" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | |
| 13 | PE = "1" |
| 14 | |
| 15 | BRANCH = "onetbb_2021" |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 16 | SRCREV = "8b829acc65569019edb896c5150d427f288e8aba" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 17 | SRC_URI = "git://github.com/oneapi-src/oneTBB.git;protocol=https;branch=${BRANCH} \ |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 18 | file://0001-hwloc_detection.cmake-remove-cross-compiation-check.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 19 | " |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 22 | inherit cmake pkgconfig |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 23 | |
| 24 | # test build fails, error: 'mallinfo mallinfo()' is deprecated |
| 25 | EXTRA_OECMAKE += " \ |
| 26 | -DTBB_TEST=OFF \ |
| 27 | -DCMAKE_BUILD_TYPE=Release \ |
| 28 | " |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 29 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 30 | # Hard-float 'd' ABI can't be used for a target that doesn't support the D instruction set extension (ignoring target-abi) |
| 31 | # tmp-glibc/work/riscv64-oe-linux/tbb/1_2021.7.0-r0/recipe-sysroot-native/usr/bin/riscv64-oe-linux/riscv64-oe-linux-ld: /tmp/lto-llvm-264bc2.o: can't link soft-float modules with double-float modules |
| 32 | # tmp-glibc/work/riscv64-oe-linux/tbb/1_2021.7.0-r0/recipe-sysroot-native/usr/bin/riscv64-oe-linux/riscv64-oe-linux-ld: failed to merge target specific data of file /tmp/lto-llvm-264bc2.o |
| 33 | EXTRA_OECMAKE:append:riscv32:toolchain-clang = " -DTBB_ENABLE_IPO=OFF " |
| 34 | EXTRA_OECMAKE:append:riscv64:toolchain-clang = " -DTBB_ENABLE_IPO=OFF " |
| 35 | |
| 36 | # fails with thumb enabled: |
| 37 | # | arm-oe-linux-gnueabi-g++ -march=armv7-a -mthumb -mthumb-interwork -mfloat-abi=softfp -mfpu=neon -mtune=cortex-a9 -mcpu=cortex-a9 -D__ARM__ -D__LINUX_ARM_ARCH__=7 -funwind-tables -mvectorize-with-neon-quad -rdynamic --sysroot=/OE/sysroots/m14tv -c -MMD -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD -fPIC -D__TBB_BUILD=1 -Wall -Wno-parentheses -Wno-non-virtual-dtor -O2 -pipe -g -feliminate-unused-debug-types -fpermissive -fvisibility-inlines-hidden -I../../src -I../../src/rml/include -I../../include ../../src/tbb/concurrent_queue.cpp |
| 38 | # | {standard input}: Assembler messages: |
| 39 | # | {standard input}:250: Error: thumb conditional instruction should be in IT block -- `strexeq r2,r3,[r4]' |
| 40 | # ... |
| 41 | # | make[1]: *** [concurrent_queue.o] Error 1 |
| 42 | ARM_INSTRUCTION_SET = "arm" |
| 43 | |
| 44 | ASNEEDED = "" |
| 45 | |
| 46 | LDFLAGS:append:mips = " -latomic" |
| 47 | LDFLAGS:append:mipsel = " -latomic" |
| 48 | LDFLAGS:append:riscv32:toolchain-clang = " -latomic" |
| 49 | |
| 50 | LDFLAGS:append:libc-musl = " -lucontext" |
| 51 | |
| 52 | # The latest version of oneTBB does not support PPC |
| 53 | COMPATIBLE_MACHINE:powerpc = "(!.*ppc).*" |
| 54 | |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 55 | |
| 56 | do_install:append:class-target() { |
| 57 | # fix for qa check buildpaths |
| 58 | sed -i "s#${RECIPE_SYSROOT}##g" ${D}${libdir}/cmake/TBB/TBBTargets.cmake |
| 59 | } |
| 60 | |
| 61 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 62 | BBCLASSEXTEND = "native nativesdk" |