blob: f834726bd6c565d5252a37b9b091ec2f000042c9 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Parallelism library for C++ - runtime files \
2 TBB is a library that helps you leverage multi-core processor \
3 performance without having to be a threading expert. It represents a \
4 higher-level, task-based parallelism that abstracts platform details \
5 and threading mechanism for performance and scalability."
6HOMEPAGE = "https://software.intel.com/en-us/tbb"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=86d3f3a95c324c9479bd8986968f4327"
9
10DEPENDS:append:libc-musl = " libucontext"
Patrick Williamsda295312023-12-05 16:48:56 -060011DEPENDS:append:class-target = " hwloc"
Andrew Geissler517393d2023-01-13 08:55:19 -060012
13PE = "1"
14
15BRANCH = "onetbb_2021"
Patrick Williamsda295312023-12-05 16:48:56 -060016SRCREV = "8b829acc65569019edb896c5150d427f288e8aba"
Andrew Geissler517393d2023-01-13 08:55:19 -060017SRC_URI = "git://github.com/oneapi-src/oneTBB.git;protocol=https;branch=${BRANCH} \
Patrick Williamsda295312023-12-05 16:48:56 -060018 file://0001-hwloc_detection.cmake-remove-cross-compiation-check.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060019"
20S = "${WORKDIR}/git"
21
Patrick Williamsda295312023-12-05 16:48:56 -060022inherit cmake pkgconfig
Andrew Geissler517393d2023-01-13 08:55:19 -060023
24# test build fails, error: 'mallinfo mallinfo()' is deprecated
25EXTRA_OECMAKE += " \
26 -DTBB_TEST=OFF \
27 -DCMAKE_BUILD_TYPE=Release \
28 "
Patrick Williamsda295312023-12-05 16:48:56 -060029
Andrew Geissler517393d2023-01-13 08:55:19 -060030# Hard-float 'd' ABI can't be used for a target that doesn't support the D instruction set extension (ignoring target-abi)
31# tmp-glibc/work/riscv64-oe-linux/tbb/1_2021.7.0-r0/recipe-sysroot-native/usr/bin/riscv64-oe-linux/riscv64-oe-linux-ld: /tmp/lto-llvm-264bc2.o: can't link soft-float modules with double-float modules
32# tmp-glibc/work/riscv64-oe-linux/tbb/1_2021.7.0-r0/recipe-sysroot-native/usr/bin/riscv64-oe-linux/riscv64-oe-linux-ld: failed to merge target specific data of file /tmp/lto-llvm-264bc2.o
33EXTRA_OECMAKE:append:riscv32:toolchain-clang = " -DTBB_ENABLE_IPO=OFF "
34EXTRA_OECMAKE:append:riscv64:toolchain-clang = " -DTBB_ENABLE_IPO=OFF "
35
36# fails with thumb enabled:
37# | arm-oe-linux-gnueabi-g++ -march=armv7-a -mthumb -mthumb-interwork -mfloat-abi=softfp -mfpu=neon -mtune=cortex-a9 -mcpu=cortex-a9 -D__ARM__ -D__LINUX_ARM_ARCH__=7 -funwind-tables -mvectorize-with-neon-quad -rdynamic --sysroot=/OE/sysroots/m14tv -c -MMD -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD -fPIC -D__TBB_BUILD=1 -Wall -Wno-parentheses -Wno-non-virtual-dtor -O2 -pipe -g -feliminate-unused-debug-types -fpermissive -fvisibility-inlines-hidden -I../../src -I../../src/rml/include -I../../include ../../src/tbb/concurrent_queue.cpp
38# | {standard input}: Assembler messages:
39# | {standard input}:250: Error: thumb conditional instruction should be in IT block -- `strexeq r2,r3,[r4]'
40# ...
41# | make[1]: *** [concurrent_queue.o] Error 1
42ARM_INSTRUCTION_SET = "arm"
43
44ASNEEDED = ""
45
46LDFLAGS:append:mips = " -latomic"
47LDFLAGS:append:mipsel = " -latomic"
48LDFLAGS:append:riscv32:toolchain-clang = " -latomic"
49
50LDFLAGS:append:libc-musl = " -lucontext"
51
52# The latest version of oneTBB does not support PPC
53COMPATIBLE_MACHINE:powerpc = "(!.*ppc).*"
54
Patrick Williamsda295312023-12-05 16:48:56 -060055
56do_install:append:class-target() {
57 # fix for qa check buildpaths
58 sed -i "s#${RECIPE_SYSROOT}##g" ${D}${libdir}/cmake/TBB/TBBTargets.cmake
59}
60
61
Andrew Geissler517393d2023-01-13 08:55:19 -060062BBCLASSEXTEND = "native nativesdk"