Patrick Venture | 19d2050 | 2018-10-24 11:10:32 -0700 | [diff] [blame] | 1 | SUMMARY = "Google i2c OEM commands" |
| 2 | DESCRIPTION = "Google i2c OEM commands" |
| 3 | HOMEPAGE = "https://github.com/openbmc/google-ipmi-i2c" |
| 4 | PR = "r1" |
| 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 8 | |
| 9 | inherit autotools pkgconfig |
| 10 | inherit obmc-phosphor-ipmiprovider-symlink |
| 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
| 13 | DEPENDS += "phosphor-ipmi-host" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
Patrick Williams | bb99d22 | 2022-01-24 15:55:09 -0600 | [diff] [blame] | 16 | SRC_URI = "git://github.com/openbmc/google-ipmi-i2c;branch=master;protocol=https" |
Andrew Geissler | 883a49d | 2022-02-08 20:20:05 +0000 | [diff] [blame] | 17 | SRCREV = "fb28f5e4a31ddf9b4989f4835182cb75b62a37ca" |
Patrick Venture | 19d2050 | 2018-10-24 11:10:32 -0700 | [diff] [blame] | 18 | |
Willy Tu | 4dd03ca | 2021-08-06 09:37:35 -0700 | [diff] [blame] | 19 | FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 20 | FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 21 | FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 22 | FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
Patrick Venture | 19d2050 | 2018-10-24 11:10:32 -0700 | [diff] [blame] | 23 | |
| 24 | HOSTIPMI_PROVIDER_LIBRARY += "libi2ccmds.so" |