Konstantin Aladyshev | 19abd96 | 2023-02-09 12:21:32 +0300 | [diff] [blame] | 1 | DESCRIPTION = "Transfer BMC IP address to the FPGA" |
| 2 | PR = "r1" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 5 | |
| 6 | inherit systemd |
| 7 | |
| 8 | SRC_URI = " file://ip-to-fpga.sh \ |
| 9 | file://ip-to-fpga.service \ |
| 10 | " |
| 11 | |
| 12 | S = "${WORKDIR}" |
| 13 | |
| 14 | DEPENDS = "systemd" |
| 15 | RDEPENDS:${PN} = "bash" |
| 16 | |
| 17 | SYSTEMD_SERVICE:${PN} = "ip-to-fpga.service" |
| 18 | |
| 19 | do_install() { |
| 20 | install -d ${D}${bindir} |
| 21 | install -m 0755 ${S}/ip-to-fpga.sh ${D}${bindir}/ |
| 22 | |
| 23 | install -d ${D}${systemd_system_unitdir} |
| 24 | install -m 0644 ${S}/ip-to-fpga.service ${D}${systemd_system_unitdir} |
| 25 | } |