Brad Bishop | 0e04b2e | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor fan definition example data" |
Brad Bishop | 0e04b2e | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 2 | LICENSE = "Apache-2.0" |
Brad Bishop | 6f3f0aa | 2019-09-13 12:14:05 -0400 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 4 | PROVIDES += "virtual/phosphor-fan-control-fan-config" |
| 5 | PR = "r1" |
| 6 | |
| 7 | SRC_URI = "file://fans.yaml" |
| 8 | |
| 9 | S = "${WORKDIR}" |
Brad Bishop | 0e04b2e | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 10 | |
| 11 | inherit allarch |
| 12 | inherit phosphor-fan |
| 13 | |
Brad Bishop | 0e04b2e | 2019-05-13 13:45:49 -0400 | [diff] [blame] | 14 | do_install() { |
| 15 | install -D fans.yaml ${D}${control_datadir}/fans.yaml |
| 16 | } |
| 17 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 18 | FILES:${PN} += "${control_datadir}/fans.yaml" |