Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "CHIPSEC: Platform Security Assessment Framework" |
| 2 | |
| 3 | DESCRIPTION = "CHIPSEC is a framework for analyzing the security \ |
| 4 | of PC platforms including hardware, system firmware \ |
| 5 | (BIOS/UEFI), and platform components." |
| 6 | |
| 7 | LICENSE = "GPL-2.0-only" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=bc2d1f9b427be5fb63f6af9da56f7c5d" |
| 9 | |
| 10 | DEPENDS = "virtual/kernel nasm-native" |
| 11 | |
| 12 | SRC_URI = "git://github.com/chipsec/chipsec.git;branch=main;protocol=https" |
| 13 | SRCREV = "d8c2a606bf440c32196c6289a7a458f3ae3107cc" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit module setuptools3 |
| 18 | |
| 19 | EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'" |
| 20 | |
| 21 | do_compile:append() { |
| 22 | cd ${S}/drivers/linux |
| 23 | oe_runmake KSRC=${STAGING_KERNEL_BUILDDIR} |
| 24 | } |
| 25 | |
| 26 | do_install:append() { |
| 27 | install -m 0644 ${S}/drivers/linux/chipsec.ko ${D}${PYTHON_SITEPACKAGES_DIR}/chipsec/helper/linux |
| 28 | } |
| 29 | |
| 30 | COMPATIBLE_HOST = "(i.86|x86_64).*-linux" |
| 31 | |
| 32 | FILES:${PN} += "${exec_prefix}" |
| 33 | |
| 34 | RDEPENDS:${PN} = "python3 python3-modules" |