Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Python library used to interact with Git repositories" |
| 2 | DESCRIPTION = "GitPython provides object model read and write access to \ |
| 3 | a git repository. Access repository information conveniently, alter the \ |
| 4 | index directly, handle remotes, or go down to low-level object database \ |
| 5 | access with big-files support." |
| 6 | HOMEPAGE = "http://github.com/gitpython-developers/GitPython" |
| 7 | SECTION = "devel/python" |
| 8 | LICENSE = "BSD-3-Clause" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183" |
| 10 | |
| 11 | PYPI_PACKAGE = "GitPython" |
| 12 | |
| 13 | inherit pypi python_setuptools_build_meta |
| 14 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "8ce3bcf69adfdf7c7d503e78fd3b1c492af782d58893b650adb2ac8912ddd573" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 16 | |
| 17 | DEPENDS += " ${PYTHON_PN}-gitdb" |
| 18 | |
| 19 | RDEPENDS:${PN} += " \ |
| 20 | ${PYTHON_PN}-datetime \ |
| 21 | ${PYTHON_PN}-gitdb \ |
| 22 | ${PYTHON_PN}-io \ |
| 23 | ${PYTHON_PN}-logging \ |
| 24 | ${PYTHON_PN}-math \ |
| 25 | ${PYTHON_PN}-netclient \ |
| 26 | ${PYTHON_PN}-stringold \ |
| 27 | ${PYTHON_PN}-unittest \ |
| 28 | ${PYTHON_PN}-unixadmin \ |
| 29 | git \ |
| 30 | " |
| 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |