Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 1 | SUMMARY = "Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL" |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://github.com/cedadev/ndg_httpsclient/" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://MANIFEST.in;md5=ce22c0cd986d2de3f7073cd6b5523ae0" |
| 5 | |
| 6 | SRC_URI[md5sum] = "b0fc8ea38f87d2c1ab1ed79a95c078f9" |
| 7 | SRC_URI[sha256sum] = "d72faed0376ab039736c2ba12e30695e2788c4aa569c9c3e3d72131de2592210" |
| 8 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 9 | inherit pypi setuptools3 update-alternatives |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 10 | |
| 11 | PYPI_PACKAGE = "ndg_httpsclient" |
| 12 | |
| 13 | DEPENDS += " \ |
| 14 | ${PYTHON_PN}-pyopenssl \ |
| 15 | ${PYTHON_PN}-pyasn1 \ |
| 16 | " |
| 17 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 18 | RDEPENDS:${PN} += " \ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 19 | ${PYTHON_PN}-datetime \ |
| 20 | ${PYTHON_PN}-logging \ |
| 21 | ${PYTHON_PN}-pyopenssl \ |
| 22 | ${PYTHON_PN}-pyasn1 \ |
| 23 | " |
| 24 | |
| 25 | BBCLASSEXTEND = "native nativesdk" |
| 26 | |
| 27 | UPSTREAM_CHECK_REGEX = "" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | ALTERNATIVE:${PN} = "ndg_httpclient" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 30 | ALTERNATIVE_LINK_NAME[ndg_httpclient] = "${bindir}/ndg_httpclient" |
| 31 | ALTERNATIVE_PRIORITY = "30" |