Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Linux Kernel Crypto API User Space Interface Library" |
| 2 | HOMEPAGE = "http://www.chronox.de/libkcapi.html" |
| 3 | LICENSE = "BSD | GPL-2.0" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=c78be93ed8d1637f2a3f4a83ff9d5f54" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 5 | |
| 6 | DEPENDS = "libtool" |
| 7 | |
| 8 | S = "${WORKDIR}/git" |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 9 | SRCREV = "d41284525ec8960e9a828979cfe269012b7df8db" |
| 10 | SRC_URI = "git://github.com/smuellerDD/libkcapi.git \ |
| 11 | file://0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch \ |
| 12 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | |
| 14 | inherit autotools |
| 15 | |
| 16 | PACKAGECONFIG ??= "" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 17 | PACKAGECONFIG[testapp] = "--enable-kcapi-test,,,bash" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | PACKAGECONFIG[apps] = "--enable-kcapi-speed --enable-kcapi-hasher --enable-kcapi-rngapp --enable-kcapi-encapp --enable-kcapi-dgstapp,,," |
| 19 | |
| 20 | do_install_append() { |
| 21 | # bindir contains testapp and apps. However it is always created, even |
| 22 | # when no binaries are installed (empty bin_PROGRAMS in Makefile.am), |
| 23 | rmdir --ignore-fail-on-non-empty ${D}${bindir} |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | |
| 25 | # Remove the generated binary checksum files |
| 26 | rm -f ${D}${bindir}/.*.hmac |
| 27 | rm -f ${D}${libdir}/.*.hmac |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | } |
| 29 | |
| 30 | CPPFLAGS_append_libc-musl_toolchain-clang = " -Wno-error=sign-compare" |