Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Open-source monitoring solution for your IT infrastructure" |
| 2 | DESCRIPTION = "\ |
| 3 | ZABBIX is software that monitors numerous parameters of a network and the \ |
| 4 | health and integrity of servers. ZABBIX uses a flexible notification \ |
| 5 | mechanism that allows users to configure e-mail based alerts for virtually \ |
| 6 | any event. This allows a fast reaction to server problems. ZABBIX offers \ |
| 7 | excellent reporting and data visualisation features based on the stored \ |
| 8 | data. This makes ZABBIX ideal for capacity planning. \ |
| 9 | \ |
| 10 | ZABBIX supports both polling and trapping. All ZABBIX reports and \ |
| 11 | statistics, as well as configuration parameters are accessed through a \ |
| 12 | web-based front end. A web-based front end ensures that the status of \ |
| 13 | your network and the health of your servers can be assessed from any \ |
| 14 | location. Properly configured, ZABBIX can play an important role in \ |
| 15 | monitoring IT infrastructure. This is equally true for small \ |
| 16 | organisations with a few servers and for large companies with a \ |
| 17 | multitude of servers." |
| 18 | HOMEPAGE = "http://www.zabbix.com/" |
| 19 | SECTION = "Applications/Internet" |
| 20 | LICENSE = "GPLv2+" |
| 21 | LIC_FILES_CHKSUM = "file://COPYING;md5=300e938ad303147fede2294ed78fe02e" |
| 22 | DEPENDS = "openldap virtual/libiconv" |
| 23 | |
| 24 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 25 | |
| 26 | SRC_URI = "http://jaist.dl.sourceforge.net/project/zabbix/ZABBIX%20Latest%20Stable/${PV}/${BPN}-${PV}.tar.gz \ |
| 27 | file://0001-Fix-configure.ac.patch \ |
| 28 | file://zabbix-agent.service \ |
| 29 | " |
| 30 | |
| 31 | SRC_URI[md5sum] = "489d21b464277c0d412155c7e5611a8f" |
| 32 | SRC_URI[sha256sum] = "4445f26c025009681c29c9b350aa6c4ee7b124ddcaf1609ae36c55997bcb8cf2" |
| 33 | |
| 34 | inherit autotools-brokensep linux-kernel-base pkgconfig systemd useradd |
| 35 | |
| 36 | SYSTEMD_PACKAGES = "${PN}" |
| 37 | SYSTEMD_SERVICE_${PN} = "zabbix-agent.service" |
| 38 | SYSTEMD_AUTO_ENABLE = "enable" |
| 39 | |
| 40 | USERADD_PACKAGES = "${PN}" |
| 41 | GROUPADD_PARAM_${PN} = "-r zabbix" |
| 42 | USERADD_PARAM_${PN} = "-r -g zabbix -d /var/lib/zabbix \ |
| 43 | -s /sbin/nologin -c \"Zabbix Monitoring System\" zabbix \ |
| 44 | " |
| 45 | |
| 46 | KERNEL_VERSION = "${@get_kernelversion_headers('${STAGING_KERNEL_DIR}')}" |
| 47 | |
| 48 | EXTRA_OECONF = " \ |
| 49 | --enable-dependency-tracking \ |
| 50 | --enable-agent \ |
| 51 | --enable-ipv6 \ |
| 52 | --with-net-snmp \ |
| 53 | --with-ldap=${STAGING_EXECPREFIXDIR} \ |
| 54 | --with-jabber \ |
| 55 | --with-unixodbc \ |
| 56 | --with-ssh2 \ |
| 57 | --with-sqlite3 \ |
| 58 | " |
| 59 | CFLAGS_append = " -lldap -llber" |
| 60 | |
| 61 | do_configure_prepend() { |
| 62 | export KERNEL_VERSION="${KERNEL_VERSION}" |
| 63 | } |
| 64 | |
| 65 | do_install_append() { |
| 66 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
| 67 | install -d ${D}${systemd_unitdir}/system |
| 68 | install -m 0644 ${WORKDIR}/zabbix-agent.service ${D}${systemd_unitdir}/system/ |
| 69 | sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/zabbix-agent.service |
| 70 | fi |
| 71 | } |
| 72 | |
| 73 | FILES_${PN} += "${libdir}" |
| 74 | |
| 75 | RDEPENDS_${PN} = "logrotate" |