Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | DESCRIPTION = "XML-RPC for C/C++ is programming libraries and related tools to help you \ |
| 2 | write an XML-RPC server or client in C or C++." |
| 3 | |
| 4 | HOMEPAGE = "http://xmlrpc-c.sourceforge.net/" |
| 5 | LICENSE = "BSD & MIT" |
| 6 | LIC_FILES_CHKSUM = "file://doc/COPYING;md5=aefbf81ba0750f02176b6f86752ea951" |
| 7 | |
| 8 | SRC_URI = "git://github.com/ensc/xmlrpc-c.git;branch=master \ |
| 9 | file://0001-fix-compile-failure-against-musl-C-library.patch \ |
| 10 | file://0002-fix-formatting-issues.patch \ |
| 11 | " |
| 12 | SRCREV = "81443a9dc234cc275449dbc17867ad77ae189124" |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | DEPENDS = "curl libxml2" |
| 16 | RDEPENDS_${PN} = "curl perl" |
| 17 | |
| 18 | inherit cmake |
| 19 | |
| 20 | EXTRA_OECMAKE = "-D_lib:STRING=${baselib}" |
| 21 | |
| 22 | BBCLASSEXTEND = "native" |
| 23 | |
| 24 | TARGET_CFLAGS += "-Wno-narrowing" |