John Wedig | e519d6b | 2023-12-08 14:38:41 -0800 | [diff] [blame] | 1 | SUMMARY = "Disable eSPI while the customer's host OS is running" |
| 2 | DESCRIPTION = "Disable eSPI while an untrusted host OS is running" |
| 3 | PR = "r1" |
| 4 | |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 7 | |
| 8 | inherit systemd |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://disable-espi.service \ |
| 12 | " |
| 13 | |
| 14 | DEPENDS += "systemd" |
| 15 | |
| 16 | RDEPENDS:${PN}:append = " \ |
| 17 | bare-metal-active \ |
| 18 | espi-control \ |
| 19 | " |
| 20 | |
| 21 | SYSTEMD_PACKAGES = "${PN}" |
| 22 | SYSTEMD_SERVICE:${PN} = " \ |
| 23 | disable-espi.service \ |
| 24 | " |
| 25 | |
| 26 | do_install:append() { |
| 27 | install -d ${D}${systemd_system_unitdir} |
| 28 | install -m 0644 ${WORKDIR}/disable-espi.service ${D}${systemd_system_unitdir} |
| 29 | } |