blob: ea2fe75bbc4e95065520f595224c7697e7a4d141 [file] [log] [blame]
Yong Li33170c32019-01-03 11:41:48 +08001SUMMARY = "Intel DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the Intel YAML"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7
8S = "${WORKDIR}/git"
9
10inherit autotools pkgconfig
Patrick Williams5181f432020-03-31 16:43:15 -050011inherit python3native
Yong Li33170c32019-01-03 11:41:48 +080012inherit phosphor-dbus-yaml
13
14DEPENDS += "autoconf-archive-native"
Patrick Williams5181f432020-03-31 16:43:15 -050015DEPENDS += "${PYTHON_PN}-sdbus++-native"
Yong Li33170c32019-01-03 11:41:48 +080016
17SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces"
Andrew Geisslerb311d512019-06-10 01:00:56 +000018SRCREV = "b5f2dd444c5d3808d005452417e4ae2ea28624ff"
Yong Li33170c32019-01-03 11:41:48 +080019
Yong Li33170c32019-01-03 11:41:48 +080020PACKAGECONFIG ??= "libintel_dbus"
21PACKAGECONFIG[libintel_dbus] = " \
22 --enable-libintel_dbus, \
23 --disable-libintel_dbus, \
24 systemd sdbusplus, \
Patrick Williams5181f432020-03-31 16:43:15 -050025 libsystemd \
Yong Li33170c32019-01-03 11:41:48 +080026 "
27
Jae Hyun Yoo24e16a22021-08-06 10:55:59 -070028PACKAGECONFIG:remove:class-native = "libintel_dbus"
29PACKAGECONFIG:remove:class-nativesdk = "libintel_dbus"
Yong Li33170c32019-01-03 11:41:48 +080030
Patrick Williams5181f432020-03-31 16:43:15 -050031BBCLASSEXTEND += "native nativesdk"