Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 1 | SUMMARY = "Python interface to PROJ (cartographic projections and coordinate transformations library)" |
| 2 | LICENSE = "MIT" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=dc4bb2668871655e24030dfe8d2a7ce7" |
| 4 | DEPENDS = "python3-cython proj" |
| 5 | DEPENDS:append:class-target = " python3-cython-native proj-native" |
| 6 | |
| 7 | PYPI_PACKAGE = "pyproj" |
| 8 | |
| 9 | inherit pypi setuptools3 |
| 10 | |
| 11 | SRC_URI[sha256sum] = "b3d8e14d91cc95fb3dbc03a9d0588ac58326803eefa5bbb0978d109de3304fbe" |
| 12 | |
| 13 | RDEPENDS:${PN} = "${PYTHON_PN}-certifi proj" |
| 14 | |
| 15 | export PROJ_INCDIR = "${STAGING_INCDIR}" |
| 16 | export PROJ_LIBDIR = "${STAGING_LIBDIR}" |