Andrew Neyland | 1ab2885 | 2023-09-06 14:53:57 -0500 | [diff] [blame] | 1 | inherit obmc-phosphor-systemd |
| 2 | SUMMARY = "Power Supplies monitoring for HPE RL300 Gen11" |
| 3 | SYSTEMD_AUTO_ENABLE = "enable" |
| 4 | SYSTEMD_SERVICE:${PN} = "psu2-monitoring.service psu1-monitoring.service psu2up.service psu2down.service psu1down.service psu1up.service" |
| 5 | SRC_URI:append = " file://psu2-monitoring.service file://psu1-monitoring.service file://psus-manager.sh file://psu2up.service file://psu2down.service file://psu1down.service file://psu1up.service file://psu2.json file://psu1.json file://startMonitoring1.sh file://startMonitoring2.sh" |
| 6 | |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 9 | |
| 10 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
| 11 | IMAGE_INSTALL += "power-supplies-monitoring " |
| 12 | |
| 13 | FILES:${PN} = "/usr/share/gpios/* /usr/bin/* /etc/system/*" |
| 14 | |
| 15 | do_install:append() { |
| 16 | install -d ${D}${sysconfdir}/system/ |
| 17 | install -d ${D}/usr/share/gpios |
| 18 | install -d ${D}/usr/bin |
| 19 | install -m 0644 ${WORKDIR}/psu1.json ${D}/usr/share/gpios/psu1.json |
| 20 | install -m 0644 ${WORKDIR}/psu2.json ${D}/usr/share/gpios/psu2.json |
| 21 | install -m 0644 ${WORKDIR}/psu2-monitoring.service ${D}${sysconfdir}/system/psu2-monitoring.service |
| 22 | install -m 0644 ${WORKDIR}/psu1-monitoring.service ${D}${sysconfdir}/system/psu1-monitoring.service |
| 23 | install -m 0644 ${WORKDIR}/psu2up.service ${D}${sysconfdir}/system/psu2up.service |
| 24 | install -m 0644 ${WORKDIR}/psu1up.service ${D}${sysconfdir}/system/psu1up.service |
| 25 | install -m 0644 ${WORKDIR}/psu1down.service ${D}${sysconfdir}/system/psu1down.service |
| 26 | install -m 0644 ${WORKDIR}/psu1down.service ${D}${sysconfdir}/system/psu1down.service |
| 27 | install -m 0755 ${WORKDIR}/psus-manager.sh ${D}/usr/bin/psus-manager.sh |
| 28 | install -m 0755 ${WORKDIR}/startMonitoring1.sh ${D}/usr/bin/startMonitoring1.sh |
| 29 | install -m 0755 ${WORKDIR}/startMonitoring2.sh ${D}/usr/bin/startMonitoring2.sh |
| 30 | } |