Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Automates Linux Standard Base (LSB) tests" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://wiki.debian.org/LSBInitScripts" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 3 | SECTION = "console/utils" |
| 4 | LICENSE = "GPLv2" |
| 5 | PR = "r3" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://LSB_Test.sh;beginline=3;endline=16;md5=7063bb54b04719df0716b513447f4fc0" |
| 8 | |
| 9 | SRC_URI = "file://LSB_Test.sh \ |
| 10 | file://packages_list \ |
| 11 | file://session \ |
| 12 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 13 | RDEPENDS_${PN} = "lsb rpm" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}" |
| 16 | |
| 17 | do_install() { |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | install -d ${D}/opt/lsb-test |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 19 | install -m 0755 ${S}/LSB_Test.sh ${D}/opt/lsb-test/LSB_Test.sh |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 20 | install -m 0644 ${S}/packages_list ${D}/opt/lsb-test/packages_list |
| 21 | install -m 0644 ${S}/session ${D}/opt/lsb-test/session |
| 22 | if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then |
| 23 | sed -i -e 's/lsbarch/ia32/g' -e 's/targetarch/i486/g' ${D}/opt/lsb-test/packages_list |
| 24 | sed -i -e 's/targetarch/x86/g' ${D}/opt/lsb-test/session |
| 25 | fi |
| 26 | if [ "${TARGET_ARCH}" = "x86_64" ];then |
| 27 | sed -i -e 's/lsbarch/amd64/g' -e 's/targetarch/x86_64/g' ${D}/opt/lsb-test/packages_list |
| 28 | sed -i -e 's/targetarch/x86-64/g' ${D}/opt/lsb-test/session |
| 29 | fi |
| 30 | if [ "${TARGET_ARCH}" = "powerpc" ];then |
| 31 | sed -i -e 's/lsbarch/ppc32/g' -e 's/targetarch/ppc/g' ${D}/opt/lsb-test/packages_list |
| 32 | sed -i -e 's/targetarch/PPC32/g' ${D}/opt/lsb-test/session |
| 33 | fi |
| 34 | |
| 35 | # For a ppc64 target. the default userspace is 32b. |
| 36 | # Therefore, only change the lsbarch and targetarch |
| 37 | # in the package_list when MLIB=lib64 is being used. |
| 38 | # Otherwise, by default, the ppc32 LSB packages |
| 39 | # will be downloaded by LSB_Test.sh |
| 40 | if [ "${TARGET_ARCH}" = "powerpc64" ];then |
| 41 | if [ "${PN}" != "${BPN}" ];then |
| 42 | sed -i -e 's/lsbarch/ppc64/g' -e 's/targetarch/ppc64/g' ${D}/opt/lsb-test/packages_list |
| 43 | sed -i -e 's/targetarch/PPC64/g' ${D}/opt/lsb-test/session |
| 44 | fi |
| 45 | fi |
| 46 | } |
| 47 | |
| 48 | FILES_${PN} += "/opt/lsb-test/* \ |
| 49 | " |