blob: 6bf056cc159fbe2a2a45c8ad318971d9b21f6b87 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Perl-cross build system"
2HOMEPAGE = "https://github.com/arsv/perl-cross"
3DESCRIPTION = "perl-cross provides configure script, top-level Makefile and some auxiliary files for perl, \
4with the primary emphasis on cross-compiling the source."
5SECTION = "devel"
6LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
7# README.md is taken from https://github.com/arsv/perl-cross/blob/master/README.md
8# but is not provided inside the release tarballs
9LIC_FILES_CHKSUM = "file://${WORKDIR}/README.md;md5=252fcce2026b765fee1ad74d2fb07a3b"
10
Andrew Geissler87f5cff2022-09-30 13:13:31 -050011inherit allarch github-releases
Andrew Geissler9aee5002022-03-30 16:27:02 +000012
Andrew Geissler87f5cff2022-09-30 13:13:31 -050013SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/perl-cross-${PV}.tar.gz;name=perl-cross \
Andrew Geissler9aee5002022-03-30 16:27:02 +000014 file://README.md \
15 file://0001-perl-cross-add-LDFLAGS-when-linking-libperl.patch \
16 file://determinism.patch \
17 file://0001-Makefile-check-the-file-if-patched-or-not.patch \
18 "
Andrew Geissler87f5cff2022-09-30 13:13:31 -050019GITHUB_BASE_URI = "https://github.com/arsv/perl-cross/releases/"
Andrew Geissler9aee5002022-03-30 16:27:02 +000020
Patrick Williamse760df82023-05-26 11:10:49 -050021SRC_URI[perl-cross.sha256sum] = "3e14bb4f28c83586c668c5f9f6b4e57b138b4ec2fae0271086e29d4e352670ca"
Andrew Geissler9aee5002022-03-30 16:27:02 +000022
23S = "${WORKDIR}/perl-cross-${PV}"
24
25do_configure () {
26}
27
28do_compile () {
29}
30
31do_install:class-native() {
32 mkdir -p ${D}/${datadir}/perl-cross/
33 cp -rf ${S}/* ${D}/${datadir}/perl-cross/
34 rm -rf ${D}/${datadir}/perl-cross/patches/
35}
36
37BBCLASSEXTEND = "native"
38