blob: dc21bc67c6f1c9081bfe04038b0303399b4a131d [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A library for property-based testing"
2HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
5
6PYPI_PACKAGE = "hypothesis"
7
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12 file://test_binary_search.py \
13 file://test_rle.py \
14 "
15
Patrick Williamsb542dec2023-06-09 01:26:37 -050016SRC_URI[sha256sum] = "a8ef2e0c7d5ebd90043a4ed8f6987de6a2b497b2caf6863364ff41db25971856"
Andrew Geissler517393d2023-01-13 08:55:19 -060017
18RDEPENDS:${PN} += " \
19 python3-attrs \
20 python3-compression \
21 python3-core \
22 python3-json \
Patrick Williamse760df82023-05-26 11:10:49 -050023 python3-pytest \
Andrew Geissler517393d2023-01-13 08:55:19 -060024 python3-sortedcontainers \
25 python3-statistics \
26 python3-unittest \
27 "
28
29RDEPENDS:${PN}-ptest += " \
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050030 ${PYTHON_PN}-unittest-automake-output \
Andrew Geissler517393d2023-01-13 08:55:19 -060031 "
32
33do_install_ptest() {
34 install -d ${D}${PTEST_PATH}/examples
35 install -m 0755 ${WORKDIR}/test_binary_search.py ${D}${PTEST_PATH}/examples/
36 install -m 0755 ${WORKDIR}/test_rle.py ${D}${PTEST_PATH}/examples/
37}
38
39BBCLASSEXTEND = "native nativesdk"