blob: 5604ff01e434b335c0c1abd0accb90dc14b04a1a [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order."
2HOMEPAGE = "https://pypi.org/project/ruamel.yaml/"
3AUTHOR = "Anthon van der Neut"
4
5LICENSE = "MIT"
Patrick Williamsb542dec2023-06-09 01:26:37 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=0e5f41db57c3a8d3584b450d35985ad1"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007
8PYPI_PACKAGE = "ruamel.yaml"
9
10inherit pypi setuptools3
11
Patrick Williamsb542dec2023-06-09 01:26:37 -050012SRC_URI[sha256sum] = "098ed1eb6d338a684891a72380277c1e6fc4d4ae0e120de9a447275056dda335"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000013
14RDEPENDS:${PN} += "\
15 ${PYTHON_PN}-shell \
16 ${PYTHON_PN}-datetime \
17 ${PYTHON_PN}-netclient \
18"
19
20do_install:prepend() {
21 export RUAMEL_NO_PIP_INSTALL_CHECK=1
22}
23
24BBCLASSEXTEND = "native nativesdk"