blob: 66ae34af948b5d270834cedc87e79bf892e27912 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001DESCRIPTION = "flashrom is a utility for identifying, reading, writing, verifying and erasing flash chips"
2LICENSE = "GPLv2"
3HOMEPAGE = "http://flashrom.org"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
6DEPENDS = "pciutils libusb libusb-compat"
7
8SRC_URI = "https://download.flashrom.org/releases/flashrom-v${PV}.tar.bz2 \
9 file://0001-typecast-enum-conversions-explicitly.patch \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050010 file://0001-Makefile-Check-for-last-line-only-from-preprocessed-.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050011 "
12SRC_URI[md5sum] = "7f8e4b87087eb12ecee0fcc5445b4956"
13SRC_URI[sha256sum] = "e1f8d95881f5a4365dfe58776ce821dfcee0f138f75d0f44f8a3cd032d9ea42b"
14
15S = "${WORKDIR}/flashrom-v${PV}"
16
17inherit pkgconfig
18
19do_install() {
20 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
21}