Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "flashrom is a utility for identifying, reading, writing, verifying and erasing flash chips" |
| 2 | LICENSE = "GPLv2" |
| 3 | HOMEPAGE = "http://flashrom.org" |
| 4 | |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 6 | DEPENDS = "pciutils libusb libusb-compat" |
| 7 | |
| 8 | SRC_URI = "https://download.flashrom.org/releases/flashrom-v${PV}.tar.bz2 \ |
| 9 | file://0001-typecast-enum-conversions-explicitly.patch \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 10 | file://0001-Makefile-Check-for-last-line-only-from-preprocessed-.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | " |
| 12 | SRC_URI[md5sum] = "7f8e4b87087eb12ecee0fcc5445b4956" |
| 13 | SRC_URI[sha256sum] = "e1f8d95881f5a4365dfe58776ce821dfcee0f138f75d0f44f8a3cd032d9ea42b" |
| 14 | |
| 15 | S = "${WORKDIR}/flashrom-v${PV}" |
| 16 | |
| 17 | inherit pkgconfig |
| 18 | |
| 19 | do_install() { |
| 20 | oe_runmake PREFIX=${prefix} DESTDIR=${D} install |
| 21 | } |