Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "C implementation of createrepo." |
| 2 | HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki" |
| 3 | |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | |
| 7 | SRC_URI = "git://github.com/rpm-software-management/createrepo_c \ |
| 8 | file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ |
| 9 | " |
| 10 | |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame] | 11 | SRCREV = "031f0524905c2a64a2faae555ca9d91281448d1b" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm" |
| 16 | DEPENDS_append_class-native = " file-replacement-native" |
| 17 | |
| 18 | inherit cmake pkgconfig bash-completion distutils3-base |
| 19 | |
| 20 | EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF -DENABLE_DRPM=OFF -DWITH_LIBMODULEMD=OFF" |
| 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |
| 23 | |
| 24 | # Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in |
| 25 | do_install_append_class-native() { |
| 26 | create_wrapper ${D}/${bindir}/createrepo_c \ |
| 27 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm |
| 28 | } |
| 29 | |
| 30 | do_install_append_class-nativesdk() { |
| 31 | create_wrapper ${D}/${bindir}/createrepo_c \ |
| 32 | RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm |
| 33 | rm -rf ${D}/etc |
| 34 | } |