Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Dhrystone CPU benchmark" |
| 2 | LICENSE = "PD" |
| 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/PD;md5=b3597d12946881e13cb3b548d1173851" |
| 4 | |
| 5 | SRC_URI = "http://www.netlib.org/benchmark/dhry-c;downloadfilename=dhry-c.shar \ |
| 6 | file://dhrystone.patch" |
| 7 | SRC_URI[md5sum] = "75aa5909c174eed98c134be2f56307da" |
| 8 | SRC_URI[sha256sum] = "038a7e9169787125c3451a6c941f3aca5db2d2f3863871afcdce154ef17f4e3e" |
| 9 | |
| 10 | # Need to override Makefile variables |
| 11 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 12 | |
| 13 | do_unpack() { |
| 14 | [ -d ${S} ] || mkdir -p ${S} |
| 15 | cd ${S} |
| 16 | sh ${DL_DIR}/dhry-c.shar |
| 17 | } |
| 18 | do_install() { |
| 19 | install -d ${D}${bindir} |
| 20 | install -m 0755 ${S}/dhry ${D}${bindir} |
| 21 | } |
| 22 | |
| 23 | # Prevent procedure merging as required by dhrystone.c: |
| 24 | CFLAGS += "-fno-lto" |
| 25 | |
| 26 | LDFLAGS += "-fno-lto" |