James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 1 | SUMMARY = "JSON for modern C++" |
| 2 | HOMEPAGE = "https://nlohmann.github.io/json/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=9a8ae1c2d606c432a2aa2e2de15be22a" |
| 6 | |
| 7 | SRC_URI = "git://github.com/nlohmann/json.git" |
| 8 | |
James Feist | cb07cdf | 2018-10-11 13:47:04 -0700 | [diff] [blame] | 9 | PV = "3.3.0+git${SRCPV}" |
James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 10 | |
James Feist | cb07cdf | 2018-10-11 13:47:04 -0700 | [diff] [blame] | 11 | SRCREV = "aafad2be1f3cd259a1e79d2f6fcf267d1ede9ec7" |
James Feist | e332299 | 2018-10-04 16:15:37 -0700 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit cmake |
| 16 | |
| 17 | EXTRA_OECMAKE += "-DJSON_BuildTests=OFF" |
| 18 | |
| 19 | # nlohmann-json is a header only C++ library, so the main package will be empty. |
| 20 | |
| 21 | RDEPENDS_${PN}-dev = "" |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |
James Feist | cb07cdf | 2018-10-11 13:47:04 -0700 | [diff] [blame] | 24 | |
| 25 | # other packages commonly reference the file directly as "json.hpp" |
| 26 | # create symlink to allow this usage |
| 27 | do_install_append() { |
| 28 | ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp |
| 29 | } |