blob: 9644c653ee1c39d701b696e5c700f33b8e355ddf [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "PDF transformation/inspection software"
2HOMEPAGE = "http://qpdf.sourceforge.net"
3LICENSE = "Artistic-2.0"
4SECTION = "libs"
5DEPENDS = "libpcre zlib libjpeg-turbo"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/qpdf/qpdf-${PV}.tar.gz"
8SRC_URI[sha256sum] = "88257d36a44fd5c50b2879488324dd9cafc11686ae49d8c4922a4872203ce006"
9
10LIC_FILES_CHKSUM = "file://Artistic-2.0;md5=7806296b9fae874361e6fb10072b7ee3"
11
12inherit autotools-brokensep gettext
13
14# disable random file detection for cross-compile
15EXTRA_OECONF = "--without-random \
16 --disable-static \
17 --disable-check-autofiles \
18 "
19
20LDFLAGS:append:mipsarch = " -latomic"
21LDFLAGS:append:riscv32 = " -latomic"
22
23S="${WORKDIR}/${BPN}-${PV}"
24
25# avoid Makefile returning error on 'make clean' before configure was run
26CLEANBROKEN = "1"
27
28DEBIAN_NOAUTONAME:libqpdf = "1"
29
30PACKAGES =+ "libqpdf"
31FILES:libqpdf = "${libdir}/libqpdf.so.*"
32
33RDEPENDS:${PN} = "libqpdf"