Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "UNIX Shell similar to the Korn shell" |
| 2 | DESCRIPTION = "Zsh is a shell designed for interactive use, although it is also a \ |
| 3 | powerful scripting language. Many of the useful features of bash, \ |
| 4 | ksh, and tcsh were incorporated into zsh; many original features were added." |
| 5 | HOMEPAGE = "http://www.zsh.org" |
| 6 | SECTION = "base/shell" |
| 7 | |
| 8 | LICENSE = "zsh" |
| 9 | LIC_FILES_CHKSUM = "file://LICENCE;md5=1a4c4cda3e8096d2fd483ff2f4514fec" |
| 10 | |
| 11 | DEPENDS = "ncurses bison-native libcap libpcre gdbm groff-native" |
| 12 | |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/5.8/${BP}.tar.xz" |
| 14 | SRC_URI[sha256sum] = "dcc4b54cc5565670a65581760261c163d720991f0d06486da61f8d839b52de27" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 16 | inherit autotools-brokensep gettext update-alternatives manpages |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 17 | |
| 18 | EXTRA_OECONF = " \ |
| 19 | --bindir=${base_bindir} \ |
| 20 | --enable-etcdir=${sysconfdir} \ |
| 21 | --enable-fndir=${datadir}/${PN}/${PV}/functions \ |
| 22 | --enable-site-fndir=${datadir}/${PN}/site-functions \ |
| 23 | --with-term-lib='ncursesw ncurses' \ |
| 24 | --with-tcsetpgrp \ |
| 25 | --enable-cap \ |
| 26 | --enable-multibyte \ |
| 27 | --disable-gdbm \ |
| 28 | --disable-dynamic \ |
| 29 | zsh_cv_shared_environ=yes \ |
| 30 | " |
| 31 | |
| 32 | # Configure respects --bindir from EXTRA_OECONF, but then Src/Makefile will read bindir from environment |
| 33 | export bindir="${base_bindir}" |
| 34 | |
| 35 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | ALTERNATIVE:${PN} = "sh" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 38 | ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh" |
| 39 | ALTERNATIVE_TARGET[sh] = "${base_bindir}/${BPN}" |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 40 | ALTERNATIVE_PRIORITY = "90" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 41 | |
| 42 | export AUTOHEADER = "true" |
| 43 | |
| 44 | do_configure () { |
| 45 | gnu-configize --force ${S} |
| 46 | oe_runconf |
| 47 | } |
| 48 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 49 | pkg_postinst:${PN} () { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 50 | touch $D${sysconfdir}/shells |
| 51 | grep -q "bin/zsh" $D${sysconfdir}/shells || echo /bin/zsh >> $D${sysconfdir}/shells |
| 52 | grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells |
| 53 | } |
| 54 | |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 55 | # work around QA failures with usrmerge installing zsh in /usr/bin/zsh instead of /bin/zsh |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 56 | # ERROR: QA Issue: /usr/share/zsh/5.8/functions/zed contained in package zsh requires /bin/zsh, but no providers found in RDEPENDS:zsh? [file-rdeps] |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 57 | # like bash does since https://git.openembedded.org/openembedded-core/commit/?id=4759408677a4e60c5fa7131afcb5bc184cf2f90a |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 58 | RPROVIDES:${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/zsh', '', d)}" |