Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # Note, we can probably remove the lzma option as it has be replaced with xz, |
| 2 | # and I don't think the kernel supports it any more. |
| 3 | SUMMARY = "Tools for manipulating SquashFS filesystems" |
| 4 | SECTION = "base" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 5 | LICENSE = "GPL-2" |
| 6 | LIC_FILES_CHKSUM = "file://../COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 7 | |
| 8 | PV = "4.3+gitr${SRCPV}" |
| 9 | SRCREV = "9c1db6d13a51a2e009f0027ef336ce03624eac0d" |
| 10 | SRC_URI = "git://github.com/plougher/squashfs-tools.git;protocol=https \ |
Patrick Williams | d7e9631 | 2015-09-22 08:09:05 -0500 | [diff] [blame] | 11 | file://0001-mksquashfs.c-get-inline-functions-work-with-C99.patch;striplevel=2 \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 12 | file://squashfs-tools-4.3-sysmacros.patch;striplevel=2 \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 13 | file://fix-compat.patch \ |
Brad Bishop | bba38f3 | 2018-08-23 16:11:46 +0800 | [diff] [blame] | 14 | file://0001-squashfs-tools-patch-for-CVE-2015-4645-6.patch;striplevel=2 \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 15 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 16 | UPSTREAM_CHECK_COMMITS = "1" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 17 | SRC_URI[lzma.md5sum] = "29d5ffd03a5a3e51aef6a74e9eafb759" |
| 18 | SRC_URI[lzma.sha256sum] = "c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e0880aa0fa1e" |
| 19 | |
| 20 | S = "${WORKDIR}/git/squashfs-tools" |
| 21 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 22 | # needs FNM_EXTMATCH |
| 23 | COMPATIBLE_HOST_libc-musl = 'null' |
| 24 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 25 | EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS}" |
| 26 | |
| 27 | PACKAGECONFIG ??= "gzip xz lzo lz4 lzma xattr" |
| 28 | PACKAGECONFIG[gzip] = "GZIP_SUPPORT=1,GZIP_SUPPORT=0,zlib" |
| 29 | PACKAGECONFIG[xz] = "XZ_SUPPORT=1,XZ_SUPPORT=0,xz" |
| 30 | PACKAGECONFIG[lzo] = "LZO_SUPPORT=1,LZO_SUPPORT=0,lzo" |
| 31 | PACKAGECONFIG[lz4] = "LZ4_SUPPORT=1,LZ4_SUPPORT=0,lz4" |
| 32 | PACKAGECONFIG[lzma] = "LZMA_XZ_SUPPORT=1,LZMA_XZ_SUPPORT=0,xz" |
| 33 | PACKAGECONFIG[xattr] = "XATTR_SUPPORT=1,XATTR_SUPPORT=0,attr" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 34 | |
| 35 | do_compile() { |
| 36 | oe_runmake mksquashfs unsquashfs |
| 37 | } |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 38 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 39 | do_install () { |
| 40 | install -d ${D}${sbindir} |
| 41 | install -m 0755 mksquashfs ${D}${sbindir}/ |
| 42 | install -m 0755 unsquashfs ${D}${sbindir}/ |
| 43 | } |
| 44 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 45 | ARM_INSTRUCTION_SET_armv4 = "arm" |
| 46 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 47 | ARM_INSTRUCTION_SET_armv6 = "arm" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 48 | |
| 49 | BBCLASSEXTEND = "native nativesdk" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 50 | |
| 51 | CVE_PRODUCT = "squashfs" |