Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Library for building powerful interactive command lines in Python" |
| 2 | HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "3e163f254bef5a03b146397d7c1963bd3e2812f0964bb9a24e6ec761fd28db63" |
| 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
| 10 | PYPI_PACKAGE = "prompt_toolkit" |
| 11 | |
| 12 | RDEPENDS:${PN} += " \ |
| 13 | ${PYTHON_PN}-core \ |
| 14 | ${PYTHON_PN}-six \ |
| 15 | ${PYTHON_PN}-terminal \ |
| 16 | ${PYTHON_PN}-threading \ |
| 17 | ${PYTHON_PN}-wcwidth \ |
| 18 | ${PYTHON_PN}-datetime \ |
| 19 | ${PYTHON_PN}-shell \ |
| 20 | ${PYTHON_PN}-image \ |
| 21 | ${PYTHON_PN}-asyncio \ |
| 22 | ${PYTHON_PN}-xml \ |
| 23 | " |
| 24 | |
| 25 | BBCLASSEXTEND = "native nativesdk" |