Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright OpenEmbedded Contributors |
| 3 | # |
| 4 | # SPDX-License-Identifier: MIT |
| 5 | # |
| 6 | |
| 7 | inherit kernel-arch |
| 8 | |
| 9 | # We do the dependency this way because the output is not preserved |
| 10 | # in sstate, so we must force do_compile to run (once). |
| 11 | do_configure[depends] += "make-mod-scripts:do_compile" |
| 12 | |
| 13 | export OS = "${TARGET_OS}" |
| 14 | export CROSS_COMPILE = "${TARGET_PREFIX}" |
| 15 | |
| 16 | # This points to the build artefacts from the main kernel build |
| 17 | # such as .config and System.map |
| 18 | # Confusingly it is not the module build output (which is ${B}) but |
| 19 | # we didn't pick the name. |
| 20 | export KBUILD_OUTPUT = "${STAGING_KERNEL_BUILDDIR}" |
| 21 | |
| 22 | export KERNEL_VERSION = "${@oe.utils.read_file('${STAGING_KERNEL_BUILDDIR}/kernel-abiversion')}" |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 23 | export LOCALVERSION = "${@oe.utils.read_file('${STAGING_KERNEL_BUILDDIR}/kernel-localversion')}" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 24 | KERNEL_OBJECT_SUFFIX = ".ko" |
| 25 | |
| 26 | # kernel modules are generally machine specific |
| 27 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 28 | |